<
 
 
 
 
×
>
hide You are viewing an archived web page, collected at the request of Ethereum Foundation using Archive-It. This page was captured on 03:20:09 Jun 22, 2021 , and is part of the Community collection. The information on this web page may be out of date. See All versions of this archived page. Loading media information

Running private test chain on local netork

Noob question, hoping this is the right place.

So I am trying to run a single private test chain on my local network with two nodes running on two different machines. Have successfully (I think) installed and run geth on a windows, and built and running c++eth on ubuntu. In the geth node I started a chain with a genesis block and have been successfully mining for some time. When I start the eth on the other machine, it seems to start but does not 'see'/peer with the first node and use same chain. Current block stays 0, I have not bothered to try mining on this one.

When I run nodeinfo on both I see they are trying to use the same IP address which seems to be my externally facing address (not static). I am guessing this is at least part of the problem and that I should be trying to override this somehow to use the local machine IPs as assigned by my router. However when I try to set the --public-ip option on eth it throws an error below. And I see no such option on geth anyway. Am I missing something, or completely on the wrong path here?

./eth console --network-id 2323 -C -d /home/mark/chains/777/data/ --public-ip 192.168.1.23 --listen-port 30300
(++)Ethereum
terminate called after throwing an instance of 'boost::exception_detail::clone_impl'
what(): std::exception
Aborted (core dumped)

I also see some options I guess for forcing them to connect using addPeer() enode URIs but I am guessing this won't work because both URIs have same IP included and that needs to be resolved first?

Comments

Sign In or Register to comment.