hide You are viewing an archived web page, collected at the request of Ethereum Foundation using Archive-It. This page was captured on 02:44:08 Jun 24, 2021 , and is part of the Community collection. The information on this web page may be out of date. See All versions of this archived page. Loading media information

Dependencies problem in Mix for Ubuntu

tcimolitcimoli Cagliari - ItalyMember Posts: 35
I am trying to install Mix in Ubuntu, following the guide in here.

The guide says that first cpp-ethereum and mix-ide are needed. But once I run the installation from synaptic manager, it ask for removal of the two packages and then complains that they are missing. I think there is a problem in the dependecies list.

How do I solve it?
Thank you


  • YannYann Member Posts: 40
    what does
    sudo apt-get install mix-ide
  • tcimolitcimoli Cagliari - ItalyMember Posts: 35
    After a bit of clean up , it magically worked. Thank you
  • tcimolitcimoli Cagliari - ItalyMember Posts: 35
    Hi all,
    I upgraded to Ubuntu 16.04 and I kind of lost Mix package. I then reinstalled it, but it does not work:

    [email protected]:~$ mix-ide
    mix-ide: error while loading shared libraries: libsolidity.so: cannot open shared object file: No such file or directory
    [email protected]:~$

    it searches for a library which I have not. I do not have libsolIDITY.SO , but I have the following:

    [email protected]:/usr/lib$ ls libsol*
    libsolid.so.4 libsolid.so.4.14.16

    how can i fix this?
    Thank you

  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    edited September 2016
    @tcimoli I believe it's to do with the Solidity 3.6 being an independent package now and for whatever reason completely breaks Mix-ide. As bad as Mix-ide was, it is still the only tool I know with Solidity level debugging and it's loss has made more complex contract development near impossible to debug. It's certainly put the breaks on my project.

    I've not been able to recover my Mix install and given the state of the cpp-ethereum repo have not been able to revert back to an earlier version of solidity either.

    You can try and install solc now that it's a separate package, but don't know if it will help....

  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    Have been told that Browser-Solidity has just now introduced source level debugging. Seems to have broken something else though as my import statements are now throwing errors that were there yesterday. :(
  • tcimolitcimoli Cagliari - ItalyMember Posts: 35
    Thank you. I agree with you that it 's a loss not to have Mix any more.
Sign In or Register to comment.